许多站长发现我们将服务器的php版本升级到php5.3以后DEDECMS程序在安装或访问的时候会提示 (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP') in php.ini的错误

对此我们联系了dedecms官方,官方给出的解释是由于在PHP最新的版本中增加了一个配置项目“request_order”,默认值为“GP”,这个存在一定的安全风险。这里我们建议用户将配置更改为“CGP”。

下面是解决的办法:

方法一:主机用户在控制面板的PHP版本切换里将php的版本切换为PHP5.2可解决。

方法二:如主机支持自定义PHP环境可以在控制面板里改为自定义PHP,然后提交售后问题联系帮忙修改PHP参数。

方法三:VPS以及服务器用户可以自行登陆服务器修改php.ini文件,将request_order = "GP"修改为request_order = "CGP"保存重启WEB服务可解决。